Strategic Overview
- Status
- Patched in 2.1.6
- Affected Plugin
- RTMKit for Elementor – Modular Addons, Widgets, Templates, Icon Library, GSAP Animations, MCP & Store Ready
- Affected Version
<= 2.1.5- CVSS
- 4.3Medium
- Weakness type
- CWE-352 · Cross-Site Request Forgery
- CVE
CVE-2026-62133
At a glance
CVE-2026-62133 is a medium-severity Cross-Site Request Forgery vulnerability in the RTMKit for Elementor WordPress plugin, affecting versions <= 2.1.5. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.1.6; sites on affected versions should update now. Disclosed September 2026, reported by MYUNGYONG LEE.
Vulnerability Overview
The RTMKit plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.1.5. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to perform an unauthorized action via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-352: Cross-Site Request Forgery
Reaching this weakness in RTMKit for Elementor <= 2.1.5 takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.
An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For RTMKit for Elementor the fix is 2.1.6: builds <= 2.1.5 are affected, anything from 2.1.6 onward is not.
Remediation
Update to version 2.1.6, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to RTMKit for Elementor: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: RTMKit for Elementor 2.1.6 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Other vulnerabilities in RTMKit for Elementor – Modular Addons, Widgets, Templates, Icon Library, GSAP Animations, MCP & Store Ready
- 8.8CVE-2026-3425: RTMKit Addons for Elementor <= 2.0.2 LFI
CVE-2026-3425 - 8.8CVE-2025-62065: RTMKit <= 1.6.5 Arbitrary File Upload
CVE-2025-62065 - 8.8CVE-2025-30911: RomethemeKit For Elementor Arbitrary Plugin
CVE-2025-30911 - 7.5CVE-2026-84752: RTMKit <= 2.1.5 PHP Object Injection
CVE-2026-84752 - 7.2CVE-2026-84763: RTMKit <= 2.1.5 Stored Cross-Site Scripting
CVE-2026-84763 - 6.5CVE-2026-5149: RTMKit <= 2.0.7 Arbitrary Form Submission Access
CVE-2026-5149 - 6.4CVE-2026-8351: RTMKit <= 2.0.7 Stored Cross-Site Scripting
CVE-2026-8351 - 6.4CVE-2025-8609: RTMKit Addons <= 1.6.5 Stored Cross-Site Scripting
CVE-2025-8609
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C