Strategic Overview
- Status
- Patched in 4.28.2
- Affected Plugin
- Relevanssi – A Better Search
- Affected Version
<= 4.28.1- CVSS
- 6.1Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
- CVE
CVE-2026-19985
At a glance
CVE-2026-19985 is a medium-severity Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in the Relevanssi WordPress plugin, affecting versions <= 4.28.1. It carries a CVSS score of 6.1 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 4.28.2; sites on affected versions should update now. Disclosed September 2026, reported by Mutantgun.
Vulnerability Overview
The Relevanssi – A Better Search plugin for WordPress is vulnerable to Reflected Cross-Site Scripting in versions up to, and including, 4.28.1 via the 's', 'post_types', and 'orderby' request parameters. This is due to insufficient input sanitization and output escaping in the relevanssi_debug_array() function in lib/debug.php, which dumps user-supplied query variables through print_r() inside a <pre> block without HTML escaping. The debug path is enabled by supplying the relevanssi_debug=on request parameter when the administrator has previously enabled the 'Debugging mode' setting; the gate itself is a configuration check with no capability, nonce, or logged-in check (the vendor explicitly suppresses nonce verification on that line). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a specially crafted link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-79: Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting')
Relevanssi <= 4.28.1 carries this weakness at post_types, and reaching it takes a caller who can reach the endpoint. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Relevanssi the fix is 4.28.2: builds <= 4.28.1 are affected, anything from 4.28.2 onward is not.
Remediation
Update to version 4.28.2, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to Relevanssi: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Relevanssi 4.28.2 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Relevanssi – A Better Search
- 9.8Relevanssi <= 3.3 SQL Injection
- 8.7Relevanssi <= 3.6.0 SQL Injection
- 7.5CVE-2025-4396: Relevanssi (Free) and <= 2.27.5 (Premium)
CVE-2025-4396 - 6.5CVE-2026-15941: Relevanssi and Relevanssi Premium <= 2.30.2
CVE-2026-15941 - 6.5CVE-2025-14719: Relevanssi (Free) < 2.29.0 (Premium) - Authenticated
CVE-2025-14719 - 6.3Relevanssi & Relevanssi – A Better Search Pro < 2.16.5 - Missing
- 6.1CVE-2017-1000038: Relevanssi – A Better Search <= 3.5.7.1 Stored XSS
CVE-2017-1000038 - 6.1CVE-2014-9443: Relevanssi – A Better Search < 3.3.8 XSS
CVE-2014-9443
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C