CVE-2026-109980

Related Posts for WordPress <= 3.0.0 - Missing Authorization to Authenticated (Contributor+) Sensitive Information Exposure via 'rp4wp_view' Parameter

2026-10-27 17:55
Wordfence PRISM

Strategic Overview

Status
Patched in 3.0.1
Affected Version
<= 3.0.0
CVSS
4.3Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-109980
View all Related Posts for WordPress vulnerabilities

At a glance

CVE-2026-109980 is a medium-severity Missing Authorization vulnerability in the Related Posts for WordPress WordPress plugin, affecting versions <= 3.0.0. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 3.0.1; sites on affected versions should update now. Disclosed October 2026, reported by Wordfence PRISM.

Vulnerability Overview

The Related Posts for WordPress plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 3.0.0 via the 'rp4wp_view' parameter. This makes it possible for authenticated attackers, with contributor-level access and above, to extract the titles and publication dates of all private posts site-wide, normally restricted to Editor-level users and above. The page's existing authorization check only verifies edit_posts and edit_post on a parent post the attacker owns, both of which any Contributor satisfies, leaving no effective gate against reading other authors' private posts.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-862: Missing Authorization

Related Posts for WordPress <= 3.0.0 carries this weakness at rp4wp_view, and reaching it takes an account at Contributor level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Related Posts for WordPress the fix is 3.0.1: builds <= 3.0.0 are affected, anything from 3.0.1 onward is not.

Remediation

Update to version 3.0.1, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Related Posts for WordPress 3.0.1 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C