Registration Form for WooCommerce <= 1.1.4 - Unauthenticated Privilege Escalation to 'user_roles' Parameter at Checkout
Strategic Overview
- Status
- Patched in 1.1.5
- Affected Plugin
- Registration Form for WooCommerce
- Affected Version
<= 1.1.4- CVSS
- 9.8Critical
- Weakness type
- CWE-269 · Improper Privilege Management
- CVE
CVE-2026-119075
At a glance
CVE-2026-119075 is a critical-severity Improper Privilege Management vulnerability in the Registration Form for WooCommerce WordPress plugin, affecting versions <= 1.1.4. It carries a CVSS score of 9.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 1.1.5; sites on affected versions should update now. Disclosed November 2026, reported by JB Sabit.
Vulnerability Overview
The Registration Form for WooCommerce plugin for WordPress is vulnerable to privilege escalation due to a missing allow-list check in the FormHandler::validate_checkout_fields() function in versions up to, and including, 1.1.4 The My Account registration path (validate_fields()) validates a submitted 'tgwcfb/user-roles' value against the form's configured allowed roles, but the checkout registration path (validate_checkout_fields(), hooked to woocommerce_after_checkout_validation) stores the raw $_POST['user_roles'] value in $this->valid_data without any allow-list enforcement, and add_user_data() then injects that value into woocommerce_new_customer_data as the new account's role. This makes it possible for unauthenticated attackers to elevate their privileges to Administrator by supplying a user_roles=administrator parameter when creating an account during checkout, resulting in full site takeover.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-269: Improper Privilege Management
Registration Form for WooCommerce <= 1.1.4 carries this weakness at user_roles, and reaching it takes no account at all. Improper privilege management means the code lets an account end up with capabilities its role should not have.
It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For Registration Form for WooCommerce the fix is 1.1.5: builds <= 1.1.4 are affected, anything from 1.1.5 onward is not.
Remediation
Update to version 1.1.5, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Registration Form for WooCommerce 1.1.5 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Registration Form for WooCommerce
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C