CVE-2026-103917

Quiz and Survey Master (QSM) <= 11.2.7 - Unauthenticated Arbitrary Shortcode Execution via 'qsm_unique_key' Parameter

2026-11-06 18:16
Kuba

Strategic Overview

Status
Patched in 11.2.8
Affected Version
<= 11.2.7
CVSS
6.5Medium
Weakness type
CWE-94 · Improper Control of Generation of Code
CVE
CVE-2026-103917
View all Quiz and Survey Master (QSM) – Quiz Maker & Survey Maker vulnerabilities

At a glance

CVE-2026-103917 is a medium-severity Improper Control of Generation of Code vulnerability in the Quiz and Survey Master (QSM) WordPress plugin, affecting versions <= 11.2.7. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 11.2.8; sites on affected versions should update now. Disclosed November 2026, reported by Kuba.

Vulnerability Overview

The The Quiz and Survey Master (QSM) – Quiz Maker & Survey Maker plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 11.2.7. This is due to the software allowing users to execute an action that does not properly validate a value before running do_shortcode. This makes it possible for unauthenticated attackers to execute arbitrary shortcodes. The submission nonce is dispensed to any unauthenticated caller by the public wp_ajax_nopriv_qsm_create_quiz_nonce endpoint, meaning it functions as a CSRF token rather than an authorization barrier and imposes no meaningful obstacle to exploitation.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-94: Improper Control of Generation of Code

Reaching this weakness in Quiz and Survey Master (QSM) <= 11.2.7 takes no account at all. Code injection means input from a request reaches a language construct that evaluates code, so the attacker's text is executed rather than treated as data.

The injected code runs with the web server's privileges, giving the attacker the same access to the database and filesystem as WordPress itself. For Quiz and Survey Master (QSM) the fix is 11.2.8: builds <= 11.2.7 are affected, anything from 11.2.8 onward is not.

Remediation

Update to version 11.2.8, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: Quiz and Survey Master (QSM) 11.2.8 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Scanner
  • Login Security

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C