CVE-2026-121516

QODE Wishlist for WooCommerce <= 1.2.9 - Unauthenticated Stored Cross-Site Scripting via 'table_title' Shared Wishlist Field via Guest Cookie

Strategic Overview

Status
Patched in 1.3.0
Affected Version
<= 1.2.9
CVSS
6.1Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-121516
View all QODE Wishlist for WooCommerce vulnerabilities

At a glance

CVE-2026-121516 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the QODE Wishlist for WooCommerce WordPress plugin, affecting versions <= 1.2.9. It carries a CVSS score of 6.1 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.3.0; sites on affected versions should update now. Disclosed November 2026, reported by Mohamed Amgad Khater (mamgad).

Vulnerability Overview

The QODE Wishlist for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'qode_wishlist_for_woocommerce_guests_items' parameter in all versions up to, and including, 1.2.9 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is exploitable by guests because the required wp_rest nonce is publicly emitted to unauthenticated visitors on the /wishlist/ page, and the attacker controls the transient key, meaning the payload is stored site-wide and only requires a victim to open a crafted share URL and click the injected title link. Successful exploitation additionally requires an action by an administrator — the attacker cannot trigger the vulnerability on their own.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.

CWE-79: Improper Neutralization of Input During Web Page Generation

QODE Wishlist for WooCommerce <= 1.2.9 carries this weakness at qode_wishlist_for_woocommerce_guests_items, and reaching it takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For QODE Wishlist for WooCommerce the fix is 1.3.0: builds <= 1.2.9 are affected, anything from 1.3.0 onward is not.

Remediation

Update to version 1.3.0, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: QODE Wishlist for WooCommerce 1.3.0 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C