CVE-2026-92885

Qode Membership <= 2.0.6.2 - Authentication Bypass via Social Login

2026-10-26 20:13
0xwackydawg

Strategic Overview

Status
Patched in 2.0.6.3
Affected Plugin
Qode Membership
Affected Version
<= 2.0.6.2
CVSS
9.8Critical
Weakness type
CWE-287 · Improper Authentication
CVE
CVE-2026-92885
View all Qode Membership vulnerabilities

At a glance

CVE-2026-92885 is a critical-severity Improper Authentication vulnerability in the Qode Membership WordPress plugin, affecting versions <= 2.0.6.2. It carries a CVSS score of 9.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 2.0.6.3; sites on affected versions should update now. Disclosed October 2026, reported by 0xwackydawg.

Vulnerability Overview

The Qode Membership plugin for WordPress is vulnerable to Authentication Bypass leading to Account Takeover in all versions up to, and including, 2.0.6.2 via the qode_membership_check_facebook_user AJAX action. This is due to a typographic error in the Facebook OAuth token verification guard within the qode_membership_login_user_from_social_network function — the guard condition tests an undefined variable ($check_social_useqoder instead of $check_social_user), causing empty() to always return true and rendering the Graph API token verification branch dead code, leaving wp_set_auth_cookie() reachable with no credential or token validation whatsoever. This makes it possible for unauthenticated attackers to log in as any existing WordPress account — including Administrator-level accounts — by supplying a known or enumerated administrator login name (rather than an email address) in the response[email] parameter, which the fallback path in get_user_by('login', $email) resolves to the matching account. Exploitation does require harvesting a valid qode_validate_facebook_login nonce, but this nonce is rendered on any public front-end page containing the [qode_user_login] or [qode_user_register] shortcode and is therefore obtainable without any prior authentication.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-287: Improper Authentication

Qode Membership <= 2.0.6.2 carries this weakness at login, and reaching it takes a caller who can reach the endpoint. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.

An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For Qode Membership the fix is 2.0.6.3: builds <= 2.0.6.2 are affected, anything from 2.0.6.3 onward is not.

Remediation

Update to version 2.0.6.3, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Qode Membership 2.0.6.3 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C