CVE-2026-115183

Qi Addons For Elementor <= 1.11.1 - Authenticated (Contributor+) Arbitrary HTML Injection

2026-10-23 00:00
Karthik Ramakrishnan

Strategic Overview

Status
Patched in 1.11.2
Affected Version
<= 1.11.1
CVSS
6.3Medium
Weakness type
CWE-345 · Insufficient Verification of Data Authenticity
CVE
CVE-2026-115183
View all Qi Addons For Elementor vulnerabilities

At a glance

CVE-2026-115183 is a medium-severity Insufficient Verification of Data Authenticity vulnerability in the Qi Addons For Elementor WordPress plugin, affecting versions <= 1.11.1. It carries a CVSS score of 6.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 1.11.2; sites on affected versions should update now. Disclosed October 2026, reported by Karthik Ramakrishnan.

Vulnerability Overview

The Qi Addons For Elementor plugin for WordPress is vulnerable to Content Injection in all versions up to, and including, 1.11.1. This is due to insufficient sanitization of the animated text widget heading due to html_entity_decode() being called before wp_kses, allowing encoded HTML tags to be decoded into live markup that bypassed the allowlist. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary HTML, including forms that submit data to external hosts, into pages via the Animated Text widget heading field. The attacker must have at least Contributor-level access to create or edit posts containing Elementor content.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-345: Insufficient Verification of Data Authenticity

The product does not sufficiently verify the origin or authenticity of data, in a way that causes it to accept invalid data.

Remediation

Update to version 1.11.2, or a newer patched version

How does WordSec protect against this?

The fix is the thing that ends this: Qi Addons For Elementor 1.11.2 closes this, and updating the plugin is the step that ends it.

  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C