Pochipp <= 1.20.2 - Reflected Cross-Site Scripting via 'keyword' Parameter
Strategic Overview
- Status
- Patched in 1.20.3
- Affected Plugin
- Pochipp
- Affected Version
<= 1.20.2- CVSS
- 6.1Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-92967
At a glance
CVE-2026-92967 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Pochipp WordPress plugin, affecting versions <= 1.20.2. It carries a CVSS score of 6.1 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.20.3; sites on affected versions should update now. Disclosed September 2026, reported by Dmitrii Ignatyev.
Vulnerability Overview
The Pochipp plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'keyword' parameter in versions up to, and including, 1.20.2. This is due to insufficient output escaping , which reads $_GET['keyword'], applies only sanitize_text_field() (which strips tags but leaves double quotes intact) and interpolates the value directly into the value attribute of the search input via a PHP heredoc, without esc_attr(). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user with upload_files capability (Author or above) into performing an action such as clicking on a specially crafted link to /wp-admin/media-upload.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-79: Improper Neutralization of Input During Web Page Generation
Pochipp <= 1.20.2 carries this weakness at keyword, and reaching it takes a caller who can reach the endpoint. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Pochipp the fix is 1.20.3: builds <= 1.20.2 are affected, anything from 1.20.3 onward is not.
Remediation
Update to version 1.20.3, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to Pochipp: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Pochipp 1.20.3 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C