CVE-2026-76058

PayPal Brasil para WooCommerce <= 1.7.8 - Missing Authorization to Unauthenticated Payment Gateway Modification via 'bcdc_activation_update' Action

2026-10-27 18:10
Wordfence PRISM

Strategic Overview

Status
Patched in 1.7.9
Affected Version
<= 1.7.8
CVSS
5.3Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-76058
View all PayPal Brasil para WooCommerce vulnerabilities

At a glance

CVE-2026-76058 is a medium-severity Missing Authorization vulnerability in the PayPal Brasil para WooCommerce WordPress plugin, affecting versions <= 1.7.8. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.7.9; sites on affected versions should update now. Disclosed October 2026, reported by Wordfence PRISM.

Vulnerability Overview

The PayPal Brasil para WooCommerce plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.7.8. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to disable or enable the PayPal Brasil BCDC payment gateway and overwrite its WooCommerce gateway settings, removing PayPal from checkout for all customers.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-862: Missing Authorization

Reaching this weakness in PayPal Brasil para WooCommerce <= 1.7.8 takes no account at all. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For PayPal Brasil para WooCommerce the fix is 1.7.9: builds <= 1.7.8 are affected, anything from 1.7.9 onward is not.

Remediation

Update to version 1.7.9, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: PayPal Brasil para WooCommerce 1.7.9 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Other vulnerabilities in PayPal Brasil para WooCommerce

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C