PPWP <= 1.9.26 - Unauthenticated Stored Cross-Site Scripting via '[ppwp]' Shortcode 'desc_below_form' Attribute via Placeholder Marker Collision
Strategic Overview
- Status
- Patched in 1.9.27
- Affected Plugin
- PPWP – Password Protect Pages
- Affected Version
<= 1.9.26- CVSS
- 7.2High
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-116520
At a glance
CVE-2026-116520 is a high-severity Improper Neutralization of Input During Web Page Generation vulnerability in the PPWP WordPress plugin, affecting versions <= 1.9.26. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.9.27; sites on affected versions should update now. Disclosed October 2026, reported by Sawyer.
Vulnerability Overview
The PPWP – Password Protect Pages plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'comment / shortcode attribute desc_below_form (and placeholder as the marker-smuggling helper)' parameter in all versions up to, and including, 1.9.26 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. This is exploitable by unauthenticated attackers because WordPress's comment_content filter leaves bare shortcode text (containing no HTML tags) untouched, and the comment_whitelist setting auto-approves subsequent comments from a previously approved name and email without administrator intervention.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
Reaching this weakness in PPWP <= 1.9.26 takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For PPWP the fix is 1.9.27: builds <= 1.9.26 are affected, anything from 1.9.27 onward is not.
Remediation
Update to version 1.9.27, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: PPWP 1.9.27 closes this, and updating the plugin is the step that ends it.
- Firewall
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in PPWP – Password Protect Pages
- 8.8CVE-2026-0551: PPWP – Password Protect Pages PHP Object Injection
CVE-2026-0551 - 5.3CVE-2024-11280: PPWP Content Restriction Bypass to Info Exposure
CVE-2024-11280 - 5.3CVE-2024-0620: PPWP Protection Mechanism Bypass
CVE-2024-0620 - 4.3CVE-2025-11729: PPWP Improper Authorization
CVE-2025-11729 - 4.3CVE-2025-10005: Password Protect WordPress Lite IDOR
CVE-2025-10005 - 4.3CVE-2026-57634: PPWP – Password Protect Pages <= 1.9.19 IDOR
CVE-2026-57634 - 4.3CVE-2026-32562: PPWP – Password Protect Pages Missing Authorization
CVE-2026-32562 - 4.3CVE-2025-5998: PPWP – Password Protect Pages Content Exposure
CVE-2025-5998
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C