Page and Post Restriction <= 1.6.1 - Unauthenticated Authentication Bypass via REST API Nonce Bypass via Cookie Re-Authentication
Strategic Overview
- Status
- Patched in 1.6.2
- Affected Plugin
- Page and Post Restriction
- Affected Version
<= 1.6.1- CVSS
- 6.5Medium
- Weakness type
- CWE-287 · Improper Authentication
- CVE
CVE-2026-118194
At a glance
CVE-2026-118194 is a medium-severity Improper Authentication vulnerability in the Page and Post Restriction WordPress plugin, affecting versions <= 1.6.1. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires no authentication. The issue is fixed in version 1.6.2; sites on affected versions should update now. Disclosed October 2026, reported by Wordfence PRISM.
Vulnerability Overview
The Page and Post Restriction plugin for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 1.6.1 This is due to the `papr_restrict_page_post_rest_api()` function, hooked on `rest_pre_dispatch`, re-authenticating the current user from the `wordpress_logged_in` cookie via `wp_set_current_user()` for any GET or HEAD REST request where the current user is 0, without verifying a REST nonce — silently undoing the nonce-zeroing that WordPress core's `rest_cookie_check_errors()` performs on cookie-authenticated requests that lack an `X-WP-Nonce` header or `_wpnonce` parameter. Combined with WordPress's permissive REST CORS behavior — which echoes the request `Origin` and sets `Access-Control-Allow-Credentials: true` — this allows an unauthenticated attacker to read REST API GET responses as a logged-in victim, exposing role-restricted and private post/page content, victim user profile data via `/wp-json/wp/v2/users/me`, and comments the victim is authorized to see. This requires the attacker to lure a logged-in user into visiting an attacker-controlled page that issues credentialed cross-origin `fetch` requests against the target site's REST API; no nonce or further victim interaction beyond the page visit is needed.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site. A successful exploit has high impact on confidentiality.
CWE-287: Improper Authentication
Page and Post Restriction <= 1.6.1 carries this weakness at papr_restrict_page_post_rest_api(), and reaching it takes no account at all. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.
An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For Page and Post Restriction the fix is 1.6.2: builds <= 1.6.1 are affected, anything from 1.6.2 onward is not.
Remediation
Update to version 1.6.2, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Page and Post Restriction 1.6.2 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in Page and Post Restriction
- 7.5CVE-2026-12000: Page and Post Restriction <= 1.4.1 Info Exposure
CVE-2026-12000 - 5.5CVE-2022-1027: Page Restriction WordPress <= 1.2.6 Admin+ Stored XSS
CVE-2022-1027 - 5.3CVE-2026-114696: Page and Post Restriction Missing Authorization
CVE-2026-114696 - 5.3CVE-2024-11297: Page Restriction WordPress Content Restriction Bypass
CVE-2024-11297 - 5.3CVE-2024-0681: Page Restriction WordPress Protection Mechanism Bypass
CVE-2024-0681
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C