Login with OTP <= 1.6 - Unauthenticated Authentication Bypass via OTP Brute Force
Strategic Overview
- Status
- Patched in 1.7
- Affected Plugin
- Login with OTP
- Affected Version
<= 1.6- CVSS
- 9.8Critical
- Weakness type
- CWE-307 · Improper Restriction of Excessive Authentication Attempts
- CVE
CVE-2026-8760
At a glance
CVE-2026-8760 is a critical-severity Improper Restriction of Excessive Authentication Attempts vulnerability in the Login with OTP WordPress plugin, affecting versions <= 1.6. It carries a CVSS score of 9.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 1.7; sites on affected versions should update now. Disclosed May 2026, reported by Irwan Kusuma.
Vulnerability Overview
The Login with OTP plugin for WordPress is vulnerable to authentication bypass in all versions up to, and including, 1.6. This is due to an incomplete fix for CVE-2024-11178: the rate-limit/lockout check added to `otpl_login_action()` was placed only inside the OTP-generation branch and is never evaluated on the OTP-validation branch, and the generated 6-digit OTP additionally has no expiration. This makes it possible for unauthenticated attackers to brute-force the 900,000-value OTP space for any user account (including administrators) and obtain a valid `wp_set_auth_cookie()` session, leading to full site compromise.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.
CWE-307: Improper Restriction of Excessive Authentication Attempts
The product does not implement sufficient measures to prevent multiple failed authentication attempts within a short time frame.
Remediation
Update to version 1.7, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Login with OTP 1.7 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in Login with OTP
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C