CVE-2026-3253

MailerLite – Signup forms (official) <= 1.7.21 - Missing Authorization to Authenticated (Contributor+) Form Creation and Deletion

Strategic Overview

Status
Patched in 1.7.22
Affected Version
<= 1.7.21
CVSS
4.3Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-3253
View all MailerLite – Signup forms (official) vulnerabilities

At a glance

CVE-2026-3253 is a medium-severity Missing Authorization vulnerability in the MailerLite WordPress plugin, affecting versions <= 1.7.21. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 1.7.22; sites on affected versions should update now. Disclosed September 2026, reported by Tarcísio Luchesi De Almeida Silva (Poystick).

Vulnerability Overview

The MailerLite – Signup forms (official) plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the forms() method of the AdminController class in all versions up to, and including, 1.7.21. This makes it possible for authenticated attackers, with Contributor-level access and above, to create or delete arbitrary signup forms.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-862: Missing Authorization

MailerLite <= 1.7.21 carries this weakness at forms(), and reaching it takes an account at Contributor level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For MailerLite the fix is 1.7.22: builds <= 1.7.21 are affected, anything from 1.7.22 onward is not.

Remediation

Update to version 1.7.22, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: MailerLite 1.7.22 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C