CVE-2026-101325

Newsletters <= 4.18.1 - Authenticated (Subscriber+) SQL Injection via 'id' Parameter

2026-10-30 20:12
zickzick2

Strategic Overview

Status
Patched in 4.18.2
Affected Plugin
Newsletters
Affected Version
<= 4.18.1
CVSS
5.3Medium
Weakness type
CWE-89 · Improper Neutralization of Special Elements used in an SQL Command
CVE
CVE-2026-101325
View all Newsletters vulnerabilities

At a glance

CVE-2026-101325 is a medium-severity Improper Neutralization of Special Elements used in an SQL Command vulnerability in the Newsletters WordPress plugin, affecting versions <= 4.18.1. It carries a CVSS score of 5.3 (reachable over the network; high confidentiality impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 4.18.2; sites on affected versions should update now. Disclosed October 2026, reported by zickzick2.

Vulnerability Overview

The Newsletters plugin for WordPress is vulnerable to time-based SQL Injection via the 'id' parameter in all versions up to, and including, 4.18.1 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. An attacker can obtain the required nonce and subscriberauth cookie without a WordPress account by simply subscribing through the public newsletter form and opening the management link sent via email; the ownership check verifies only the subscriber_id field and does not validate that the injected id parameter belongs to the authenticated subscriber.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, and no interaction from a victim user. A successful exploit has high impact on confidentiality.

CWE-89: Improper Neutralization of Special Elements used in an SQL Command

Reaching this weakness in Newsletters <= 4.18.1 takes an account at Subscriber level or above. SQL injection happens when request data is concatenated into a query instead of being bound as a parameter, letting an attacker change the structure of the statement rather than just its values.

A working injection can read any table the database user can see, which on a WordPress install means user records, password hashes and session or API secrets stored in options. For Newsletters the fix is 4.18.2: builds <= 4.18.1 are affected, anything from 4.18.2 onward is not.

Remediation

Update to version 4.18.2, or a newer patched version

How does WordSec protect against this?

An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Newsletters 4.18.2 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C