MW WP Form <= 5.1.7 - Unauthenticated Sensitive Information Exposure in 'post_id' Parameter
Strategic Overview
- Status
- Patched in 5.1.8
- Affected Plugin
- MW WP Form
- Affected Version
<= 5.1.7- CVSS
- 5.3Medium
- Weakness type
- CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
- CVE
CVE-2026-92086
At a glance
CVE-2026-92086 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the MW WP Form WordPress plugin, affecting versions <= 5.1.7. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 5.1.8; sites on affected versions should update now. Disclosed October 2026, reported by RIA Labs.
Vulnerability Overview
The MW WP Form plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 5.1.7 via the 'post_id' parameter. This makes it possible for unauthenticated attackers to extract personally identifiable information from other users' form inquiry records, including submitted names, email addresses, and free-text message bodies, by enumerating sequential post IDs. Exploitation requires the targeted form to have the querystring setting enabled, but this is a standard documented feature of the plugin.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
MW WP Form <= 5.1.7 carries this weakness at post_id, and reaching it takes no account at all. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.
The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For MW WP Form the fix is 5.1.8: builds <= 5.1.7 are affected, anything from 5.1.8 onward is not.
Remediation
Update to version 5.1.8, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: MW WP Form 5.1.8 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in MW WP Form
- 9.8CVE-2023-6316: MW WP Form <= 5.0.1 Arbitrary File Upload
CVE-2023-6316 - 8.1CVE-2026-5436: MW WP Form <= 5.1.1 Arbitrary File Move
CVE-2026-5436 - 8.1CVE-2026-4347: MW WP Form <= 5.1.0 Arbitrary File Move
CVE-2026-4347 - 7.5CVE-2023-6559: MW WP Form Improper Limitation of File Name
CVE-2023-6559 - 7.2CVE-2026-96567: MW WP Form <= 5.1.7 Stored Cross-Site Scripting
CVE-2026-96567 - 7.2CVE-2026-48871: MW WP Form <= 5.1.3 Stored Cross-Site Scripting
CVE-2026-48871 - 6.5CVE-2026-78363: MW WP Form < 5.1.5 Arbitrary Shortcode Execution
CVE-2026-78363 - 5.5CVE-2024-24804: MW WP Form <= 5.0.6 Stored Cross-Site Scripting
CVE-2024-24804
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C