CVE-2026-16750

Motors – Car Dealership & Classified Listings <= 1.4.120 - Missing Authorization to Unauthenticated Private/Draft/Password-Protected Listings Exposure

2026-09-17 08:50
Niv Kochan

Strategic Overview

Status
Patched in 1.4.121
Affected Version
<= 1.4.120
CVSS
5.3Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-16750
View all Motors – Car Dealership & Classified Listings Plugin vulnerabilities

At a glance

CVE-2026-16750 is a medium-severity Missing Authorization vulnerability in the Motors WordPress plugin, affecting versions <= 1.4.120. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.4.121; sites on affected versions should update now. Disclosed September 2026, reported by Niv Kochan.

Vulnerability Overview

The Motors – Car Dealership & Classified Listings Plugin plugin for WordPress is vulnerable to unauthorized access of data due to missing authorization checks in mvl_ajax_dealer_load_cars() function in all versions up to, and including, 1.4.120. This makes it possible for unauthenticated attackers to retrieve draft, pending, private, and future car listings belonging to arbitrary users.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-862: Missing Authorization

Motors <= 1.4.120 carries this weakness at mvl_ajax_dealer_load_cars(), and reaching it takes no account at all. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Motors the fix is 1.4.121: builds <= 1.4.120 are affected, anything from 1.4.121 onward is not.

Remediation

Update to version 1.4.121, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Motors 1.4.121 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C