CVE-2026-109216

Meta Box <= 5.15.2 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Background Field Array Keys

Strategic Overview

Status
Patched in 5.15.3
Affected Version
<= 5.15.2
CVSS
4.9Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-109216
View all Meta Box – A Framework for Dynamic Websites vulnerabilities

At a glance

CVE-2026-109216 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Meta Box WordPress plugin, affecting versions <= 5.15.2. It carries a CVSS score of 4.9 (reachable over the network). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 5.15.3; sites on affected versions should update now. Disclosed October 2026, reported by Md. Moniruzzaman Prodhan (NomanProdhan).

Vulnerability Overview

The Meta Box – A Framework for Dynamic Websites plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'profile_background[<attacker-chosen key>]' parameter in all versions up to, and including, 5.15.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitability depends on a consuming plugin or theme built on Meta Box that exposes the background field to lower-privileged users and renders stored values via the rwmb_the_value()/format_single_value() pattern; the effective minimum privilege is whatever role that consumer permits, demonstrated at Subscriber level.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

Meta Box <= 5.15.2 carries this weakness at rwmb_the_value(), and reaching it takes an account at Subscriber level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Meta Box the fix is 5.15.3: builds <= 5.15.2 are affected, anything from 5.15.3 onward is not.

Remediation

Update to version 5.15.3, or a newer patched version

How does WordSec protect against this?

An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Meta Box 5.15.3 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C