CVE-2025-11168

Mementor Core <= 2.2.5 - Authenticated (Subscriber+) Privilege Escalation

2025-11-10 15:06
theviper17y

Strategic Overview

Status
Patched in 3.0.0
Affected Plugin
Mementor Core
Affected Version
<= 2.2.5
CVSS
8.8High
Weakness type
CWE-269 · Improper Privilege Management
CVE
CVE-2025-11168
View all Mementor Core vulnerabilities

At a glance

CVE-2025-11168 is a high-severity Improper Privilege Management vulnerability in the Mementor Core WordPress plugin, affecting versions <= 2.2.5. It carries a CVSS score of 8.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 3.0.0; sites on affected versions should update now. Disclosed November 2025, reported by theviper17y.

Vulnerability Overview

The Mementor Core plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 2.2.5. This is due to plugin not properly handling the user switch back function. This makes it possible for authenticated attackers, with Subscriber-level access and above, to elevate their privileges by accessing an administrator account through the switch back functionality.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-269: Improper Privilege Management

Reaching this weakness in Mementor Core <= 2.2.5 takes an account at Subscriber level or above. Improper privilege management means the code lets an account end up with capabilities its role should not have.

It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For Mementor Core the fix is 3.0.0: builds <= 2.2.5 are affected, anything from 3.0.0 onward is not.

Remediation

Update to version 3.0.0, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Mementor Core 3.0.0 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C