CVE-2026-92797

Memberpress <= 1.14.1 - Cross-Site Request Forgery via 'user_email' Parameter

2026-10-27 00:00
Matthew Cowan

Strategic Overview

Status
Patched in 1.14.2
Affected Plugin
Memberpress
Affected Version
<= 1.14.1
CVSS
8.8High
Weakness type
CWE-352 · Cross-Site Request Forgery (CSRF)
CVE
CVE-2026-92797
View all Memberpress vulnerabilities

At a glance

CVE-2026-92797 is a high-severity Cross-Site Request Forgery (CSRF) vulnerability in the Memberpress WordPress plugin, affecting versions <= 1.14.1. It carries a CVSS score of 8.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 1.14.2; sites on affected versions should update now. Disclosed October 2026, reported by Matthew Cowan.

Vulnerability Overview

The MemberPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.14.1. This is due to a bypassable nonce verification check in the save_profile_fields() function that uses an isset() condition at line 1119, allowing the security check to be completely bypassed by simply omitting the nonce parameter from the request. This makes it possible for unauthenticated attackers to change authenticated users' email addresses via a forged request granted they can trick an authenticated user into performing an action such as clicking on a link, leading to account takeover through password reset functionality.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-352: Cross-Site Request Forgery (CSRF)

Memberpress <= 1.14.1 carries this weakness at save_profile_fields(), and reaching it takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.

An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For Memberpress the fix is 1.14.2: builds <= 1.14.1 are affected, anything from 1.14.2 onward is not.

Remediation

Update to version 1.14.2, or a newer patched version

How does WordSec protect against this?

The attempt arrives as an ordinary request to Memberpress: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Memberpress 1.14.2 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C