CVE-2026-115820

Majestic Support <= 1.2.2 - Authenticated (Subscriber+) SQL Injection via 'columns' Parameter

2026-10-30 17:08
sermsak

Strategic Overview

Status
Patched in 1.2.3
Affected Version
<= 1.2.2
CVSS
6.5Medium
Weakness type
CWE-89 · Improper Neutralization of Special Elements used in an SQL Command
CVE
CVE-2026-115820
View all Majestic Support – The Leading-Edge Help Desk & Customer Support Plugin vulnerabilities

At a glance

CVE-2026-115820 is a medium-severity Improper Neutralization of Special Elements used in an SQL Command vulnerability in the Majestic Support WordPress plugin, affecting versions <= 1.2.2. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 1.2.3; sites on affected versions should update now. Disclosed October 2026, reported by sermsak.

Vulnerability Overview

The Majestic Support – The Leading-Edge Help Desk & Customer Support Plugin plugin for WordPress is vulnerable to generic SQL Injection via the 'columns (array keys)' parameter in all versions up to, and including, 1.2.2 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with subscriber-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database. Any authenticated WordPress user with Subscriber-level access can exploit this because the 'saveusereraserequest' task is whitelisted for front-end customer use, the plugin auto-provisions a help-desk record for every WordPress account, and the only guard is a nonce the attacker legitimately obtains from their own 'Add erase request' page.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality.

CWE-89: Improper Neutralization of Special Elements used in an SQL Command

Majestic Support <= 1.2.2 carries this weakness at saveusereraserequest, and reaching it takes an account at Subscriber level or above. SQL injection happens when request data is concatenated into a query instead of being bound as a parameter, letting an attacker change the structure of the statement rather than just its values.

A working injection can read any table the database user can see, which on a WordPress install means user records, password hashes and session or API secrets stored in options. For Majestic Support the fix is 1.2.3: builds <= 1.2.2 are affected, anything from 1.2.3 onward is not.

Remediation

Update to version 1.2.3, or a newer patched version

How does WordSec protect against this?

An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Majestic Support 1.2.3 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C