CVE-2026-113616

LogixFast Auth <= 1.0.3 - Unauthenticated Privilege Escalation via Account Takeover

2026-10-27 00:00
Naoki Kawahigashi

Strategic Overview

Status
Patched in 1.0.4
Affected Plugin
LogixFast Auth
Affected Version
<= 1.0.3
CVSS
9.8Critical
Weakness type
CWE-269 · Improper Privilege Management
CVE
CVE-2026-113616
View all LogixFast Auth vulnerabilities

At a glance

CVE-2026-113616 is a critical-severity Improper Privilege Management vulnerability in the LogixFast Auth WordPress plugin, affecting versions <= 1.0.3. It carries a CVSS score of 9.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires no authentication. The issue is fixed in version 1.0.4; sites on affected versions should update now. Disclosed October 2026, reported by Naoki Kawahigashi.

Vulnerability Overview

The LogixFast Auth plugin for WordPress is vulnerable to privilege escalation via account takeover in all versions up to, and including, 1.0.3. This is due to the plugin not properly validating a user's identity prior to updating their password. This makes it possible for unauthenticated attackers to change arbitrary user's password, including administrators, and leverage that to gain access to their account.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-269: Improper Privilege Management

Reaching this weakness in LogixFast Auth <= 1.0.3 takes no account at all. Improper privilege management means the code lets an account end up with capabilities its role should not have.

It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For LogixFast Auth the fix is 1.0.4: builds <= 1.0.3 are affected, anything from 1.0.4 onward is not.

Remediation

Update to version 1.0.4, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: LogixFast Auth 1.0.4 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C