CVE-2026-93389

LiteSpeed Cache <= 7.9.1 - Unauthenticated Sensitive Information Disclosure (WooCommerce Store API Cart/Checkout PII + Cart-Token) via Public REST Caching

2026-11-04 16:09
Santh

Strategic Overview

Status
Patched in 7.9.2
Affected Plugin
LiteSpeed Cache
Affected Version
<= 7.9.1
CVSS
8.2High
Weakness type
CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
CVE
CVE-2026-93389
View all LiteSpeed Cache vulnerabilities

At a glance

CVE-2026-93389 is a high-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the LiteSpeed Cache WordPress plugin, affecting versions <= 7.9.1. It carries a CVSS score of 8.2 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires no authentication. The issue is fixed in version 7.9.2; sites on affected versions should update now. Disclosed November 2026, reported by Santh.

Vulnerability Overview

The LiteSpeed Cache plugin for WordPress is vulnerable to unauthenticated disclosure of sensitive WooCommerce customer data in all versions up to, and including, 7.9.1 With Cache REST enabled (the shipped default cache-rest=1), LiteSpeed stores WooCommerce Store API GET responses (/wc/store/v1/cart and /wc/store/v1/checkout) as PUBLIC cache objects and does not vary the cache on the Cart-Token or WooCommerce session. A shopper's personalized cart/checkout response is therefore served to any later, cookie-less and token-less client as an LSCache HIT. This makes it possible for unauthenticated attackers to read another shopper's billing and shipping details (name, company, street address, email, phone), cart contents and totals, and the shopper's live Cart-Token session JWT and nonce (enabling cart/checkout-session hijack), plus order_key on the checkout endpoint.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality.

CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Reaching this weakness in LiteSpeed Cache <= 7.9.1 takes no account at all. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.

The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For LiteSpeed Cache the fix is 7.9.2: builds <= 7.9.1 are affected, anything from 7.9.2 onward is not.

Remediation

Update to version 7.9.2, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: LiteSpeed Cache 7.9.2 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C