CVE-2025-58785

Ray Enterprise Translation <= 1.7.4 - Missing Authorization

2025-09-05 00:00
LVT-tholv2k

Strategic Overview

Status
Patched in 1.7.5
Affected Version
<= 1.7.4
CVSS
6.5Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2025-58785
View all Ray Enterprise Translation vulnerabilities

At a glance

CVE-2025-58785 is a medium-severity Missing Authorization vulnerability in the Ray Enterprise Translation WordPress plugin, affecting versions <= 1.7.4. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high integrity impact). The root cause is a missing authorization check on a reachable function. The issue is fixed in version 1.7.5; sites on affected versions should update now. Disclosed September 2025, reported by LVT-tholv2k.

Vulnerability Overview

The Ray Enterprise Translation plugin for WordPress is vulnerable to unauthorized access due to a missing capability check on a function in all versions up to, and including, 1.7.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to perform an unauthorized action.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on integrity.

CWE-862: Missing Authorization

Reaching this weakness in Ray Enterprise Translation <= 1.7.4 takes a caller who can reach the endpoint. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Ray Enterprise Translation the fix is 1.7.5: builds <= 1.7.4 are affected, anything from 1.7.5 onward is not.

Remediation

Update to version 1.7.5, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Ray Enterprise Translation 1.7.5 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C