LifterLMS <= 10.3.2 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Content Question Answer
Strategic Overview
- Status
- Patched in 11.0.0
- Affected Plugin
- LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes
- Affected Version
<= 10.3.2- CVSS
- 6.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-119098
At a glance
CVE-2026-119098 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the LifterLMS WordPress plugin, affecting versions <= 10.3.2. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 11.0.0; sites on affected versions should update now. Disclosed November 2026, reported by UKO.
Vulnerability Overview
The LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'answer[]' parameter in all versions up to, and including, 10.3.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the attacker to be enrolled as a student in a course containing a Content-type quiz question; the injected payload executes in the administrator's browser session during the normal grading workflow when 'Start a Review' is clicked on the affected attempt.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
LifterLMS <= 10.3.2 carries this weakness at answer[], and reaching it takes an account at Subscriber level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For LifterLMS the fix is 11.0.0: builds <= 10.3.2 are affected, anything from 11.0.0 onward is not.
Remediation
Update to version 11.0.0, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: LifterLMS 11.0.0 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in LifterLMS – WP LMS for eLearning, Online Courses, & Quizzes
- 9.8CVE-2020-6008: LifterLMS Wordpress Plugin Arbitrary File Write
CVE-2020-6008 - 8.8CVE-2026-104723: LifterLMS <= 10.2.1 PHP Object Injection
CVE-2026-104723 - 8.8CVE-2025-11923: LifterLMS Various Versions - Authenticated (Student+)
CVE-2025-11923 - 8.8CVE-2024-4743: LifterLMS – WordPress LMS for eLearning SQL Injection
CVE-2024-4743 - 7.5CVE-2026-110284: LifterLMS <= 10.3.1 Local File Inclusion
CVE-2026-110284 - 7.5CVE-2025-52717: LifterLMS <= 8.0.6 SQL Injection
CVE-2025-52717 - 7.5CVE-2021-24562: LMS by LifterLMS IDOR
CVE-2021-24562 - 7.2CVE-2024-7349: LifterLMS <= 7.7.5 SQL Injection
CVE-2024-7349
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C