CVE-2025-32113

Libro de Reclamaciones y Quejas <= 1.2 - Cross-Site Request Forgery to Stored Cross-Site Scripting

2025-04-04 00:00
SOPROBRO

Strategic Overview

Status
Patched in 1.3
Affected Version
<= 1.2
CVSS
6.1Medium
Weakness type
CWE-352 · Cross-Site Request Forgery
CVE
CVE-2025-32113
View all Libro de Reclamaciones y Quejas vulnerabilities

At a glance

CVE-2025-32113 is a medium-severity Cross-Site Request Forgery vulnerability in the Libro de Reclamaciones y Quejas WordPress plugin, affecting versions <= 1.2. It carries a CVSS score of 6.1 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.3; sites on affected versions should update now. Disclosed April 2025, reported by SOPROBRO.

Vulnerability Overview

The Libro de Reclamaciones y Quejas plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.2. This is due to missing or incorrect nonce validation on a function. This makes it possible for unauthenticated attackers to update settings and inject malicious web scripts via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.

CWE-352: Cross-Site Request Forgery

Reaching this weakness in Libro de Reclamaciones y Quejas <= 1.2 takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.

An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For Libro de Reclamaciones y Quejas the fix is 1.3: builds <= 1.2 are affected, anything from 1.3 onward is not.

Remediation

Update to version 1.3, or a newer patched version

How does WordSec protect against this?

The attempt arrives as an ordinary request to Libro de Reclamaciones y Quejas: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Libro de Reclamaciones y Quejas 1.3 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C