Appointment Booking Plugin <= 5.7.6 - Unauthenticated Stored Cross-Site Scripting via Customer Email Field
Strategic Overview
- Status
- Patched in 5.7.7
- Affected Version
<= 5.7.6- CVSS
- 5.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-119152
At a glance
CVE-2026-119152 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Appointment Booking Plugin WordPress plugin, affecting versions <= 5.7.6. It carries a CVSS score of 5.4 (reachable over the network). Exploitation requires no authentication. The issue is fixed in version 5.7.7; sites on affected versions should update now. Disclosed November 2026, reported by Maciej Komorowski.
Vulnerability Overview
The Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'customer[email] (inside params)' parameter in all versions up to, and including, 5.7.6 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. An unauthenticated visitor can exploit this by registering as a LatePoint customer via the public booking form — receiving an active customer session with no WordPress account — and then submitting a quoted local-part email address containing an HTML payload (e.g. a tag with no spaces) that passes FILTER_VALIDATE_EMAIL but is stored and rendered unescaped.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
Reaching this weakness in Appointment Booking Plugin <= 5.7.6 takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Appointment Booking Plugin the fix is 5.7.7: builds <= 5.7.6 are affected, anything from 5.7.7 onward is not.
Remediation
Update to version 5.7.7, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Appointment Booking Plugin 5.7.7 closes this, and updating the plugin is the step that ends it.
- Firewall
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Appointment Booking Plugin – LatePoint | Calendar & Scheduling for WordPress
- 9.8CVE-2025-6715: LatePoint <= 5.1.93 Local File Inclusion
CVE-2025-6715 - 9.8CVE-2024-8943: LatePoint <= 5.0.12 Authentication Bypass
CVE-2024-8943 - 9.8CVE-2024-8911: LatePoint <= 5.0.11 Arbitrary User Password Change
CVE-2024-8911 - 9.1CVE-2026-110653: Appointment Booking Plugin Authentication Bypass
CVE-2026-110653 - 9.1CVE-2026-92966: Appointment Booking Arbitrary Shortcode Execution
CVE-2026-92966 - 9.1CVE-2024-2472: LatePoint Missing Authorization and Info Exposure
CVE-2024-2472 - 8.8CVE-2026-104766: Appointment Booking Privilege Escalation
CVE-2026-104766 - 8.8CVE-2026-13228: LatePoint Privilege Escalation to Administrator
CVE-2026-13228
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C