CVE-2026-42694

Kirki – Freeform Page Builder, Website Builder & Customizer <= 6.4.0 - Authenticated (Subscriber+) Arbitrary Page Content Injection

2026-10-29 00:00
nh4tvd

Strategic Overview

Status
Patched in 6.4.1
Affected Version
<= 6.4.0
CVSS
3.5Low
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-42694
View all Kirki – Freeform Page Builder, Website Builder & Customizer vulnerabilities

At a glance

CVE-2026-42694 is a low-severity Missing Authorization vulnerability in the Kirki WordPress plugin, affecting versions <= 6.4.0. It carries a CVSS score of 3.5 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 6.4.1; sites on affected versions should update now. Disclosed October 2026, reported by nh4tvd.

Vulnerability Overview

The Kirki – Freeform Page Builder, Website Builder & Customizer plugin for WordPress is vulnerable to Cross-Site Scripting in all versions up to, and including, 6.4.0. This is due to missing post type validation on the user-supplied symbol_id parameter in the symbol update AJAX handler, allowing any post ID to be targeted. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary block content into any page on the site by supplying a non-symbol post ID to the symbol update endpoint.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed.

CWE-862: Missing Authorization

Reaching this weakness in Kirki <= 6.4.0 takes an account at Subscriber level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For Kirki the fix is 6.4.1: builds <= 6.4.0 are affected, anything from 6.4.1 onward is not.

Remediation

Update to version 6.4.1, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Kirki 6.4.1 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C