Kali Forms <= 2.4.29 - Authenticated (Subscriber+) Information Exposure
Strategic Overview
- Status
- Patched in 2.4.30
- Affected Plugin
- Kali Forms — Contact Form & Drag-and-Drop Builder
- Affected Version
<= 2.4.29- CVSS
- 4.3Medium
- Weakness type
- CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
- CVE
CVE-2026-107342
At a glance
CVE-2026-107342 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the Kali Forms WordPress plugin, affecting versions <= 2.4.29. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 2.4.30; sites on affected versions should update now. Disclosed October 2026, reported by Usama Arshad.
Vulnerability Overview
The Kali Forms plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.4.29. This makes it possible for authenticated attackers, with subscriber-level access and above, to extract sensitive user or configuration data.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
Reaching this weakness in Kali Forms <= 2.4.29 takes an account at Subscriber level or above. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.
The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For Kali Forms the fix is 2.4.30: builds <= 2.4.29 are affected, anything from 2.4.30 onward is not.
Remediation
Update to version 2.4.30, or a newer patched version
How does WordSec protect against this?
The fix is the thing that ends this: Kali Forms 2.4.30 closes this, and updating the plugin is the step that ends it.
- Alerts
External References
Related records
Other vulnerabilities in Kali Forms — Contact Form & Drag-and-Drop Builder
- 9.8CVE-2026-3584: Kali Forms <= 2.4.9 Remote Code Execution
CVE-2026-3584 - 8.8CVE-2020-36717: Kali Forms <= 2.1.1 Cross-Site Request Forgery
CVE-2020-36717 - 8.6CVE-2020-36712: Kali Forms <= 2.1.1 Arbitrary Post Deletion
CVE-2020-36712 - 8.1CVE-2026-16144: Kali Forms <= 2.4.20 Remote Code Execution
CVE-2026-16144 - 8.1CVE-2026-59542: Kali Forms Arbitrary File Deletion
CVE-2026-59542 - 7.6CVE-2024-1217: Contact Form builder… Arbitrary Plugin Deactivation
CVE-2024-1217 - 7.2CVE-2026-65446: Kali Forms <= 2.4.18 Stored Cross-Site Scripting
CVE-2026-65446 - 7.2CVE-2026-15395: Kali Forms <= 2.4.18 Stored Cross-Site Scripting
CVE-2026-15395
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C