CVE-2026-119219

Jupiter X Core <= 4.62.0 - Unauthenticated Stored Cross-Site Scripting via Raven Register Custom User Meta

2026-11-06 14:00
Rafie Muhammad

Strategic Overview

Status
Patched in 4.63.0
Affected Plugin
Jupiter X Core
Affected Version
<= 4.62.0
CVSS
5.4Medium
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-119219
View all Jupiter X Core vulnerabilities

At a glance

CVE-2026-119219 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Jupiter X Core WordPress plugin, affecting versions <= 4.62.0. It carries a CVSS score of 5.4 (reachable over the network). Exploitation requires no authentication. The issue is fixed in version 4.63.0; sites on affected versions should update now. Disclosed November 2026, reported by Rafie Muhammad.

Vulnerability Overview

The Jupiter X Core plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'fields[<custom_meta_field_id>]' parameter in all versions up to, and including, 4.62.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Execution requires that the attacker-registered account be assigned as the post_author of a page or post whose template includes the Raven Author Box widget, a fixture an administrator can create by reassigning authorship to any user including newly registered Subscribers.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

Reaching this weakness in Jupiter X Core <= 4.62.0 takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Jupiter X Core the fix is 4.63.0: builds <= 4.62.0 are affected, anything from 4.63.0 onward is not.

Remediation

Update to version 4.63.0, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Jupiter X Core 4.63.0 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C