Jupiter X Core <= 4.61.0 - Authenticated (Contributor+) Stored Cross-Site Scripting via 'forget_password_link' Parameter
Strategic Overview
- Status
- Patched in 4.62.0
- Affected Plugin
- Jupiter X Core
- Affected Version
<= 4.61.0- CVSS
- 6.4Medium
- Weakness type
- CWE-80 · Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)
- CVE
CVE-2026-10511
At a glance
CVE-2026-10511 is a medium-severity Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in the Jupiter X Core WordPress plugin, affecting versions <= 4.61.0. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 4.62.0; sites on affected versions should update now. Disclosed October 2026, reported by theviper17y.
Vulnerability Overview
The Jupiter X Core plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'forget_password_link' parameter in all versions up to, and including, 4.61.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-80: Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS)
The product receives input from an upstream component, but it does not neutralize or incorrectly neutralizes special characters such as <, >, and & that could be interpreted as web-scripting elements when they are sent to a downstream component that processes web pages.
Remediation
Update to version 4.62.0, or a newer patched version
How does WordSec protect against this?
An attacker needs Contributor access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Jupiter X Core 4.62.0 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Other vulnerabilities in Jupiter X Core
- 9.9CVE-2022-1654: Jupiter Theme and JupiterX Core Plugin <= 2.0.7
CVE-2022-1654 - 9.8CVE-2024-7772: Jupiter X Core <= 4.6.5 Arbitrary File Upload
CVE-2024-7772 - 9.8CVE-2023-38388: JupiterX Core <= 3.3.5 Arbitrary File Upload
CVE-2023-38388 - 9.8CVE-2023-38389: JupiterX Core <= 3.3.8 Privilege Escalation
CVE-2023-38389 - 8.8CVE-2026-3533: JupiterX Core <= 4.14.1 Limited File Upload
CVE-2026-3533 - 8.8CVE-2025-0366: Jupiter X Core SVG Upload to Local File Inclusion (RCE)
CVE-2025-0366 - 8.3CVE-2023-38385: JupiterX Core 3.0.0 - 3.3.0 Missing Authorization
CVE-2023-38385 - 8.1CVE-2025-2105: Jupiter X Core <= 4.8.11 PHP Object Injection
CVE-2025-2105
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C