WPBakery Page Builder <= 9.0.1 - Authenticated (Subscriber+) Stored Cross-Site Scripting via Post Author Display Name
Strategic Overview
- Status
- Patched in 9.1
- Affected Plugin
- WPBakery Page Builder
- Affected Version
<= 9.0.1- CVSS
- 6.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-119165
At a glance
CVE-2026-119165 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the WPBakery Page Builder WordPress plugin, affecting versions <= 9.0.1. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 9.1; sites on affected versions should update now. Disclosed November 2026, reported by Rafie Muhammad.
Vulnerability Overview
The WPBakery Page Builder plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'display_name / nickname' parameter in all versions up to, and including, 9.0.1 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful execution requires that at least one public post attributed to the attacker's account be rendered through a Basic Grid using a Grid Builder template with the Post Author element configured to link to the post author; Author-level users can satisfy this precondition unassisted, while Subscribers depend on an administrator having assigned or published a post under their account.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
Reaching this weakness in WPBakery Page Builder <= 9.0.1 takes an account at Subscriber level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For WPBakery Page Builder the fix is 9.1: builds <= 9.0.1 are affected, anything from 9.1 onward is not.
Remediation
Update to version 9.1, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: WPBakery Page Builder 9.1 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in WPBakery Page Builder
- 8.8CVE-2024-5709: WPBakery <= 7.7 Local File Inclusion
CVE-2024-5709 - 6.4CVE-2025-11161: WPBakery Page Builder <= 8.6.1 Stored XSS
CVE-2025-11161 - 6.4CVE-2025-11160: WPBakery Page Builder <= 8.6.1 Stored XSS
CVE-2025-11160 - 6.4CVE-2025-4968: WPBakery Page Builder <= 8.4.1 Stored XSS
CVE-2025-4968 - 6.4CVE-2025-4965: WPBakery Page Builder <= 8.4.1 Stored XSS
CVE-2025-4965 - 6.4CVE-2024-5708: WPBakery <= 7.7 Stored Cross-Site Scripting
CVE-2024-5708 - 6.4CVE-2024-5265: WPBakery Page Builder <= 7.6 Stored XSS
CVE-2024-5265 - 6.4CVE-2024-1841: WPBakery Visual Composer <= 7.5 Stored XSS
CVE-2024-1841
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C