CVE-2026-5336

Dataverse Integration <= 2.90 - Authenticated (Contributor+) Server-Side Template Injection to Information Exposure

2026-06-02 00:00
dangnosuy

Strategic Overview

Status
Patched in 2.91
Affected Version
<= 2.90
CVSS
4.3Medium
Weakness type
CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
CVE
CVE-2026-5336
View all DataPress (Dataverse Integration) vulnerabilities

At a glance

CVE-2026-5336 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the DataPress (Dataverse Integration) WordPress plugin, affecting versions <= 2.90. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Contributor level or above. The issue is fixed in version 2.91; sites on affected versions should update now. Disclosed June 2026, reported by dangnosuy.

Vulnerability Overview

The DataPress (Dataverse Integration) plugin for WordPress is vulnerable to Server-Side Template Injection in all versions up to, and including, 2.90. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive information.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-200: Exposure of Sensitive Information to an Unauthorized Actor

Reaching this weakness in DataPress (Dataverse Integration) <= 2.90 takes an account at Contributor level or above. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.

The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For DataPress (Dataverse Integration) the fix is 2.91: builds <= 2.90 are affected, anything from 2.91 onward is not.

Remediation

Update to version 2.91, or a newer patched version

How does WordSec protect against this?

The fix is the thing that ends this: DataPress (Dataverse Integration) 2.91 closes this, and updating the plugin is the step that ends it.

  • Alerts

External References

Related records

Other vulnerabilities in DataPress (Dataverse Integration)

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C