CVE-2026-120554

Import and export users and customers <= 2.5.11 - Authenticated (Custom+) Privilege Escalation via Non-Atomic Cron Settings Save

2026-11-03 21:19
Abdul Halim

Strategic Overview

Status
Patched in 2.5.12
Affected Version
<= 2.5.11
CVSS
8.8High
Weakness type
CWE-863 · Incorrect Authorization
CVE
CVE-2026-120554
View all Import and export users and customers vulnerabilities

At a glance

CVE-2026-120554 is a high-severity Incorrect Authorization vulnerability in the Import and export users and customers WordPress plugin, affecting versions <= 2.5.11. It carries a CVSS score of 8.8 (reachable over the network; low attack complexity; high confidentiality, integrity, availability impact). Exploitation requires an authenticated account at Custom level or above. The issue is fixed in version 2.5.12; sites on affected versions should update now. Disclosed November 2026, reported by Abdul Halim.

Vulnerability Overview

The Import and export users and customers plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 2.5.11 This is due to a non-atomic multi-option write sequence in the `ACUI_Cron::save_settings()` function, which persists `acui_cron_activated`, `acui_cron_configured_by`, `acui_cron_user_id`, and `acui_cron_path_to_file` before reaching the authorization gate that calls `wp_die()` when a non-promoter submits a role. This makes it possible for authenticated attackers holding a custom delegated role with `create_users` but without `promote_users` or `edit_users` to escalate their privileges to Administrator, provided a prior administrator cron-tab save exists and no successful save intervenes before the next unattended cron tick processes the attacker's repointed CSV file.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity, availability — full site compromise territory.

CWE-863: Incorrect Authorization

Import and export users and customers <= 2.5.11 carries this weakness at save_settings(), and reaching it takes an account at Custom level or above. Incorrect authorization means a permission check exists but evaluates the wrong thing, so it passes for callers it was meant to stop.

The action runs for users the code intended to exclude, with the same effect as having no check at all. For Import and export users and customers the fix is 2.5.12: builds <= 2.5.11 are affected, anything from 2.5.12 onward is not.

Remediation

Update to version 2.5.12, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Import and export users and customers 2.5.12 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C