Image Slider <= 1.1.121 - Cross-Site Request Forgery to Post Duplication
Strategic Overview
- Status
- Patched in 1.1.123
- Affected Plugin
- Image Slider
- Affected Version
<= 1.1.121- CVSS
- 5.4Medium
- Weakness type
- CWE-352 · Cross-Site Request Forgery (CSRF)
- CVE
CVE-2022-2223
At a glance
CVE-2022-2223 is a medium-severity Cross-Site Request Forgery (CSRF) vulnerability in the Image Slider WordPress plugin, affecting versions <= 1.1.121. It carries a CVSS score of 5.4 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.1.123; sites on affected versions should update now. Disclosed May 2022, reported by Marco Wotschka.
Vulnerability Overview
The WordPress plugin Image Slider is vulnerable to Cross-Site Request Forgery in versions up to, and including 1.1.121 due to failure to properly check for the existence of a nonce in the function ewic_duplicate_slider. This make it possible for unauthenticated attackers to duplicate existing posts or pages granted they can trick a site administrator into performing an action such as clicking on a link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site.
CWE-352: Cross-Site Request Forgery (CSRF)
Reaching this weakness in Image Slider <= 1.1.121 takes a caller who can reach the endpoint. Cross-site request forgery abuses the fact that browsers attach a victim's cookies to any request, so a state-changing action that only checks who you are, not whether you meant to act, can be triggered from another site.
An attacker who gets a logged-in user to load a crafted page can perform that action as them, with the impact scaling to whatever the victim's role is allowed to do. For Image Slider the fix is 1.1.123: builds <= 1.1.121 are affected, anything from 1.1.123 onward is not.
Remediation
Update to version 1.1.123, or a newer patched version
How does WordSec protect against this?
The attempt arrives as an ordinary request to Image Slider: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Image Slider 1.1.123 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Other vulnerabilities in Image Slider
- 9.8Image Slider <= 1.1.95 SQL Injection
- 8.8Image Slider <= 1.1.119 Subscriber+ SQL Injection
- 8.1Image Slider < 1.1.90 Arbitrary File Deletion
- 6.4CVE-2026-42700: Image Slider <= 1.1.130 Stored Cross-Site Scripting
CVE-2026-42700 - 6.1CVE-2013-6837: PrettyPhoto Library DOM XSS
CVE-2013-6837 - 4.4CVE-2024-32707: Image Slider <= 1.1.125 Stored Cross-Site Scripting
CVE-2024-32707
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C