HT Mega Addons for Elementor <= 3.2.7 - Unauthenticated Stored DOM-Based Cross-Site Scripting via Tabs Widget href DOM Sink
Strategic Overview
- Status
- Patched in 3.2.8
- Affected Version
<= 3.2.7- CVSS
- 5.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-111318
At a glance
CVE-2026-111318 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the HT Mega Addons for Elementor WordPress plugin, affecting versions <= 3.2.7. It carries a CVSS score of 5.4 (reachable over the network). Exploitation requires no authentication. The issue is fixed in version 3.2.8; sites on affected versions should update now. Disclosed October 2026, reported by UKO.
Vulnerability Overview
The HT Mega Addons for Elementor – Elementor Widgets & Template Builder plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'href attribute of <a> inside .htmega-tab-nav' parameter in all versions up to, and including, 3.2.7 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful exploitation requires a co-installed plugin such as wpDiscuz with its rich editor enabled whose markup allowlist permits span[class] and a[href] storage, an HT Mega Tabs widget present on the same page as the comment section, and a victim user click on the injected anchor link.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
Reaching this weakness in HT Mega Addons for Elementor <= 3.2.7 takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For HT Mega Addons for Elementor the fix is 3.2.8: builds <= 3.2.7 are affected, anything from 3.2.8 onward is not.
Remediation
Update to version 3.2.8, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: HT Mega Addons for Elementor 3.2.8 closes this, and updating the plugin is the step that ends it.
- Firewall
- Login Security
- Alerts
External References
Related records
Same weakness class
- 6.4CVE-2026-11895: HT Mega Addons for Elementor <= 3.1.1 Stored XSS
CVE-2026-11895 - 6.4CVE-2026-86788: HT Mega 3.2.0 - 3.2.5 Stored Cross-Site Scripting
CVE-2026-86788 - 6.4CVE-2025-13141: HT Mega – Absolute Addons For Elementor Stored XSS
CVE-2025-13141 - 6.4CVE-2025-1802: HT Mega – Absolute Addons For Elementor Stored XSS
CVE-2025-1802
Other vulnerabilities in HT Mega Addons for Elementor – Elementor Widgets & Template Builder
- 9.8CVE-2023-37999: HT Mega Privilege Escalation
CVE-2023-37999 - 8.8CVE-2024-1974: HT Mega Directory Traversal
CVE-2024-1974 - 7.5CVE-2023-6214: HT Mega – Absolute Addons For Elementor Info Exposure
CVE-2023-6214 - 6.4CVE-2025-1261: HT Mega DOM-Based Stored XSS
CVE-2025-1261 - 6.4CVE-2024-12599: HT Mega – Absolute Addons For Elementor Stored XSS
CVE-2024-12599 - 6.4CVE-2024-12597: HT Mega <= 2.7.6 Stored Cross-Site Scripting
CVE-2024-12597 - 6.4CVE-2024-5215: HT Mega – Absolute Addons For Elementor Stored XSS
CVE-2024-5215 - 6.4CVE-2024-5173: HT Mega – Absolute Addons For Elementor Stored XSS
CVE-2024-5173
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C