Hr Press Lite <= 1.0.2 - Missing Authorization to Authenticated (Subscriber+) Sensitive Employee Information Exposure
Strategic Overview
- Status
- Patched in 1.0.3
- Affected Plugin
- HR Press Lite
- Affected Version
<= 1.0.2- CVSS
- 6.5Medium
- Weakness type
- CWE-862 · Missing Authorization
- CVE
CVE-2026-2720
At a glance
CVE-2026-2720 is a medium-severity Missing Authorization vulnerability in the HR Press Lite WordPress plugin, affecting versions <= 1.0.2. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 1.0.3; sites on affected versions should update now. Disclosed March 2026, reported by Itthidej Aramsri (Boeing777).
Vulnerability Overview
The Hr Press Lite plugin for WordPress is vulnerable to unauthorized access of sensitive employee data due to a missing capability check on the `hrp-fetch-employees` AJAX action in all versions up to, and including, 1.0.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to retrieve sensitive employee information including names, email addresses, phone numbers, salary/pay rates, employment dates, and employment status.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality.
CWE-862: Missing Authorization
Reaching this weakness in HR Press Lite <= 1.0.2 takes an account at Subscriber level or above. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.
Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For HR Press Lite the fix is 1.0.3: builds <= 1.0.2 are affected, anything from 1.0.3 onward is not.
Remediation
Update to version 1.0.3, or a newer patched version
How does WordSec protect against this?
Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: HR Press Lite 1.0.3 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C