Headless SSO Plugin for WP <= 1.7.0 - Unauthenticated Arbitrary Account Takeover
Strategic Overview
- Status
- Patched in 1.7.1
- Affected Plugin
- Headless SSO Plugin for WP
- Affected Version
<= 1.7.0- CVSS
- 7.3High
- Weakness type
- CWE-287 · Improper Authentication
- CVE
CVE-2026-62108
At a glance
CVE-2026-62108 is a high-severity Improper Authentication vulnerability in the Headless SSO Plugin for WP WordPress plugin, affecting versions <= 1.7.0. It carries a CVSS score of 7.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.7.1; sites on affected versions should update now. Disclosed September 2026, reported by Joost Grunwald.
Vulnerability Overview
The Headless SSO Plugin for WP plugin for WordPress is vulnerable to Account Takeover in all versions up to, and including, 1.7.0. This is due to a flawed account-matching condition that reduced to `username_exists($userName)` regardless of the configured matcher, allowing an IdP-asserted username to match any existing WordPress account unconditionally. This makes it possible for unauthenticated attackers to log in as any existing WordPress user, including administrators, by asserting a matching username in a crafted SAML response regardless of the configured account-matcher setting.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-287: Improper Authentication
Reaching this weakness in Headless SSO Plugin for WP <= 1.7.0 takes no account at all. Improper authentication means the mechanism that proves who a caller is can be satisfied without the secret it was supposed to require.
An attacker authenticates as another user — administrators included — without ever knowing a password, so password policies and login rate limits never come into play. For Headless SSO Plugin for WP the fix is 1.7.1: builds <= 1.7.0 are affected, anything from 1.7.1 onward is not.
Remediation
Update to version 1.7.1, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Headless SSO Plugin for WP 1.7.1 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Other vulnerabilities in Headless SSO Plugin for WP
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C