Greenshift <= 13.2.2 - Unauthenticated Sensitive Information Exposure in Nested {{COOKIE:}} Placeholder via {{GET:}} Parameter
Strategic Overview
- Status
- Patched in 13.2.3
- Affected Plugin
- Greenshift – animation and page builder blocks
- Affected Version
<= 13.2.2- CVSS
- 5.3Medium
- Weakness type
- CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
- CVE
CVE-2026-120520
At a glance
CVE-2026-120520 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the Greenshift WordPress plugin, affecting versions <= 13.2.2. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 13.2.3; sites on affected versions should update now. Disclosed November 2026, reported by jiahao.
Vulnerability Overview
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 13.2.2 via the 'img (or any key the publisher references in {{GET:key}})' parameter. This makes it possible for unauthenticated attackers to extract authenticated users' HttpOnly WordPress session cookies, specifically wordpress_logged_in_* tokens, by injecting a nested {{COOKIE:}} placeholder via a GET parameter that causes the victim's browser to transmit the cookie value to an attacker-controlled host as an image src URL. Exploitation requires that a site publisher has configured a public GreenShift Element image block whose src attribute contains a {{GET:}} placeholder, and that a logged-in user can be induced to open the attacker's crafted link — neither condition is part of the plugin's default state.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
Reaching this weakness in Greenshift <= 13.2.2 takes no account at all. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.
The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For Greenshift the fix is 13.2.3: builds <= 13.2.2 are affected, anything from 13.2.3 onward is not.
Remediation
Update to version 13.2.3, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Greenshift 13.2.3 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Greenshift – animation and page builder blocks
- 8.8CVE-2025-3616: Greenshift 11.4 - 11.4.5 Arbitrary File Upload
CVE-2025-3616 - 7.2CVE-2023-6636: Greenshift Arbitrary File Upload
CVE-2023-6636 - 6.4CVE-2026-83544: Greenshift Stored XSS
CVE-2026-83544 - 6.4CVE-2026-83543: Greenshift – animation and page builder blocks SSRF
CVE-2026-83543 - 6.4CVE-2026-5092: Greenshift <= 12.8.9 Stored Cross-Site Scripting
CVE-2026-5092 - 6.4CVE-2026-4895: Greenshift <= 12.8.9 Stored Cross-Site Scripting
CVE-2026-4895 - 6.4CVE-2026-2593: Greenshift Stored XSS
CVE-2026-2593 - 6.4CVE-2025-11841: Greenshift Stored XSS
CVE-2025-11841
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C