Greenshift <= 13.2.1 - Unauthenticated Stored DOM-Based Cross-Site Scripting via Comment Content via Split Text innerText
Strategic Overview
- Status
- Patched in 13.2.2
- Affected Plugin
- Greenshift – animation and page builder blocks
- Affected Version
<= 13.2.1- CVSS
- 5.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-107629
At a glance
CVE-2026-107629 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the Greenshift WordPress plugin, affecting versions <= 13.2.1. It carries a CVSS score of 5.4 (reachable over the network). Exploitation requires no authentication. The issue is fixed in version 13.2.2; sites on affected versions should update now. Disclosed October 2026, reported by UKO.
Vulnerability Overview
The Greenshift – animation and page builder blocks plugin for WordPress is vulnerable to Stored DOM-Based Cross-Site Scripting via the 'comment' parameter in all versions up to, and including, 13.2.1 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Exploitation requires the affected post page to include an Advanced HTML Element block with Split Text animation enabled wrapping a Latest Comments block that displays comment excerpts, as this configuration causes splittext.js to be enqueued and to process the comment content container.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
Greenshift <= 13.2.1 carries this weakness at comment, and reaching it takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For Greenshift the fix is 13.2.2: builds <= 13.2.1 are affected, anything from 13.2.2 onward is not.
Remediation
Update to version 13.2.2, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: Greenshift 13.2.2 closes this, and updating the plugin is the step that ends it.
- Firewall
- Login Security
- Alerts
External References
Related records
Same weakness class
Other vulnerabilities in Greenshift – animation and page builder blocks
- 8.8CVE-2025-3616: Greenshift 11.4 - 11.4.5 Arbitrary File Upload
CVE-2025-3616 - 7.2CVE-2023-6636: Greenshift Arbitrary File Upload
CVE-2023-6636 - 6.4CVE-2026-83543: Greenshift – animation and page builder blocks SSRF
CVE-2026-83543 - 6.4CVE-2025-11841: Greenshift Stored XSS
CVE-2025-11841 - 6.4CVE-2025-49301: Greenshift <= 11.5.5 Stored Cross-Site Scripting
CVE-2025-49301 - 6.4CVE-2025-30873: Greenshift <= 11.0.2 Stored Cross-Site Scripting
CVE-2025-30873 - 6.4CVE-2025-26884: Greenshift <= 10.8 Stored Cross-Site Scripting
CVE-2025-26884 - 6.4CVE-2024-6155: Greenshift Authenticated (Subscriber+) SSRF and Stored
CVE-2024-6155
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C