CVE-2026-111978

GiveWP <= 4.19.0.0 - Authenticated (Give Manager+) Path Traversal

2026-10-23 00:00
Karthik Ramakrishnan

Strategic Overview

Status
Patched in 4.19.0.1
Affected Version
<= 4.19.0.0
CVSS
6.5Medium
Weakness type
CWE-22 · Improper Limitation of a Pathname to a Restricted Directory
CVE
CVE-2026-111978
View all GiveWP – Donation Plugin and Fundraising Platform vulnerabilities

At a glance

CVE-2026-111978 is a medium-severity Improper Limitation of a Pathname to a Restricted Directory vulnerability in the GiveWP WordPress plugin, affecting versions <= 4.19.0.0. It carries a CVSS score of 6.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires an authenticated account at Give Manager level or above. The issue is fixed in version 4.19.0.1; sites on affected versions should update now. Disclosed October 2026, reported by Karthik Ramakrishnan.

Vulnerability Overview

The GiveWP plugin for WordPress is vulnerable to Path Traversal in all versions up to, and including, 4.19.0.0. This is due to insufficient validation of a user supplied path. This makes it possible for authenticated attackers, with give manager-level access and above, to access files and directories outside of the intended directory.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user. A successful exploit has high impact on confidentiality.

CWE-22: Improper Limitation of a Pathname to a Restricted Directory

Reaching this weakness in GiveWP <= 4.19.0.0 takes an account at Give Manager level or above. Path traversal happens when user-controlled text is used to build a filesystem path without being constrained to an intended directory, so sequences like ../ walk the resolved path somewhere else.

Depending on the operation, it means reading files outside the intended folder — wp-config.php being the usual target — or writing to and deleting paths the web server can touch. For GiveWP the fix is 4.19.0.1: builds <= 4.19.0.0 are affected, anything from 4.19.0.1 onward is not.

Remediation

Update to version 4.19.0.1, or a newer patched version

How does WordSec protect against this?

An attacker needs Give Manager access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: GiveWP 4.19.0.1 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C