GeoDirectory <= 2.8.196 - Unauthenticated Information Exposure
Strategic Overview
- Status
- Patched in 2.8.197
- Affected Version
<= 2.8.196- CVSS
- 5.3Medium
- Weakness type
- CWE-200 · Exposure of Sensitive Information to an Unauthorized Actor
- CVE
CVE-2026-114270
At a glance
CVE-2026-114270 is a medium-severity Exposure of Sensitive Information to an Unauthorized Actor vulnerability in the GeoDirectory WordPress plugin, affecting versions <= 2.8.196. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.8.197; sites on affected versions should update now. Disclosed October 2026, reported by Erwan LR.
Vulnerability Overview
The GeoDirectory plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.8.196. This makes it possible for unauthenticated attackers to extract sensitive user or configuration data.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.
CWE-200: Exposure of Sensitive Information to an Unauthorized Actor
Reaching this weakness in GeoDirectory <= 2.8.196 takes no account at all. Sensitive information exposure means data the application intended to keep internal is returned to a caller who should not be able to see it.
The disclosed data — credentials, tokens, customer records or internal paths — is usually worth more as material for a follow-up attack than as an end in itself. For GeoDirectory the fix is 2.8.197: builds <= 2.8.196 are affected, anything from 2.8.197 onward is not.
Remediation
Update to version 2.8.197, or a newer patched version
How does WordSec protect against this?
This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: GeoDirectory 2.8.197 closes this, and updating the plugin is the step that ends it.
- Login Security
- Alerts
External References
Related records
Same weakness class
- 5.3CVE-2026-113492: GeoDirectory <= 2.8.193 Information Exposure
CVE-2026-113492 - 5.3CVE-2026-113490: GeoDirectory <= 2.8.193 Information Exposure
CVE-2026-113490 - 5.3CVE-2026-16988: GeoDirectory Pending/Draft Listing Disclosure
CVE-2026-16988 - 4.3CVE-2026-16968: GeoDirectory Information Exposure
CVE-2026-16968
Other vulnerabilities in GeoDirectory – WP Business Directory Plugin and Classified Listings Directory
- 9.9CVE-2024-43145: GeoDirectory <= 2.3.61 SQL Injection
CVE-2024-43145 - 8.1CVE-2026-104899: GeoDirectory <= 2.8.187 Local File Inclusion
CVE-2026-104899 - 8.1CVE-2026-19091: GeoDirectory <= 2.8.169 Arbitrary File Deletion
CVE-2026-19091 - 7.5CVE-2026-103913: GeoDirectory <= 2.8.186 SQL Injection
CVE-2026-103913 - 7.5CVE-2026-84813: GeoDirectory SQL Injection
CVE-2026-84813 - 7.5CVE-2026-54831: GeoDirectory SQL Injection
CVE-2026-54831 - 7.5CVE-2026-39512: GeoDirectory SQL Injection
CVE-2026-39512 - 7.5CVE-2024-13507: GeoDirectory SQL Injection
CVE-2024-13507
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C