CVE-2026-113674

GeoDirectory <= 2.8.193 - Missing Authorization

2026-10-22 00:00
Vincent Suen

Strategic Overview

Status
Patched in 2.8.194
Affected Version
<= 2.8.193
CVSS
5.3Medium
Weakness type
CWE-862 · Missing Authorization
CVE
CVE-2026-113674
View all GeoDirectory – WP Business Directory Plugin and Classified Listings Directory vulnerabilities

At a glance

CVE-2026-113674 is a medium-severity Missing Authorization vulnerability in the GeoDirectory WordPress plugin, affecting versions <= 2.8.193. It carries a CVSS score of 5.3 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2.8.194; sites on affected versions should update now. Disclosed October 2026, reported by Vincent Suen.

Vulnerability Overview

The GeoDirectory plugin for WordPress is vulnerable to unauthorized access in all versions up to, and including, 2.8.193. This is due to a missing capability check on a function. This makes it possible for unauthenticated attackers to perform an unauthorized action.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-862: Missing Authorization

Reaching this weakness in GeoDirectory <= 2.8.193 takes a caller who can reach the endpoint. A missing authorization check means a function is reachable by anyone who can reach the endpoint, because the code never asks whether the caller is allowed to perform the action.

Any user who can reach the endpoint gets to run an action reserved for higher-privileged roles, from reading protected data to changing settings or content. For GeoDirectory the fix is 2.8.194: builds <= 2.8.193 are affected, anything from 2.8.194 onward is not.

Remediation

Update to version 2.8.194, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: GeoDirectory 2.8.194 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C