CVE-2026-113489

GeoDirectory <= 2.8.193 - Authenticated (Subscriber+) Insecure Direct Object Reference

2026-10-22 00:00
Karthik Ramakrishnan

Strategic Overview

Status
Patched in 2.8.194
Affected Version
<= 2.8.193
CVSS
4.3Medium
Weakness type
CWE-639 · Authorization Bypass Through User-Controlled Key
CVE
CVE-2026-113489
View all GeoDirectory – WP Business Directory Plugin and Classified Listings Directory vulnerabilities

At a glance

CVE-2026-113489 is a medium-severity Authorization Bypass Through User-Controlled Key vulnerability in the GeoDirectory WordPress plugin, affecting versions <= 2.8.193. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 2.8.194; sites on affected versions should update now. Disclosed October 2026, reported by Karthik Ramakrishnan.

Vulnerability Overview

The GeoDirectory plugin for WordPress is vulnerable to Insecure Direct Object Reference in all versions up to, and including, 2.8.193. This is due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with subscriber-level access and above, to perform an unauthorized action.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-639: Authorization Bypass Through User-Controlled Key

Reaching this weakness in GeoDirectory <= 2.8.193 takes an account at Subscriber level or above. Authorization bypass through a user-controlled key, often called insecure direct object reference, means the application looks up a record by an identifier from the request without checking that the caller owns it.

Changing a number in the request is enough to read or modify other users' records, which on commerce and membership sites means customer data. For GeoDirectory the fix is 2.8.194: builds <= 2.8.193 are affected, anything from 2.8.194 onward is not.

Remediation

Update to version 2.8.194, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: GeoDirectory 2.8.194 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C