Strategic Overview
- Status
- Patched in 4.5.5.4
- Affected Plugin
- GEO my WP
- Affected Version
<= 4.5.5.3- CVSS
- 7.5High
- Weakness type
- CWE-98 · Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')
- CVE
CVE-2026-85200
At a glance
CVE-2026-85200 is a high-severity Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in the GEO my WP WordPress plugin, affecting versions <= 4.5.5.3. It carries a CVSS score of 7.5 (reachable over the network; low attack complexity; high confidentiality impact). Exploitation requires no authentication. The issue is fixed in version 4.5.5.4; sites on affected versions should update now. Disclosed September 2026, reported by yck.
Vulnerability Overview
The GEO my WP plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 4.5.5.3 via the gmw_posts_locator_ajax_info_window_loader function. This makes it possible for unauthenticated attackers to include and execute arbitrary .php files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where .php file types can be uploaded and included. In environments where PEAR is installed with register_argc_argv enabled, this file inclusion can be leveraged to write and execute arbitrary PHP code, achieving full remote code execution.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality.
CWE-98: Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion')
Reaching this weakness in GEO my WP <= 4.5.5.3 takes no account at all. PHP file inclusion means a path used by include or require is built from request data, so the file that gets executed is under the caller's influence.
Including an attacker-influenced file executes its contents, which is why this class is routinely chained with an upload or log-poisoning step to reach code execution. For GEO my WP the fix is 4.5.5.4: builds <= 4.5.5.3 are affected, anything from 4.5.5.4 onward is not.
Remediation
Update to version 4.5.5.4, or a newer patched version
How does WordSec protect against this?
Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. Classes like this one can leave something behind, so the staged malware scanner is the second half: it looks for dropped files and modified code rather than for the request that created them. None of that substitutes for the fix: GEO my WP 4.5.5.4 closes this, and updating the plugin is the step that ends it.
- Firewall
- Scanner
- Login Security
External References
Related records
Other vulnerabilities in GEO my WP
- 9.8CVE-2024-6330: GEO my WordPress <= 4.5.0.1 Local File Inclusion
CVE-2024-6330 - 9.1CVE-2026-15300: GEO my WP <= 4.5.4 SQL Injection
CVE-2026-15300 - 7.5CVE-2026-52715: GEO my WP <= 4.5.5 SQL Injection
CVE-2026-52715 - 7.5CVE-2026-9757: GEO my WP <= 4.5.5 SQL Injection
CVE-2026-9757 - 7.5GEO my WP <= 4.5.4 SQL Injection
- 7.2CVE-2024-9422: GEO My WordPress <= 4.4.0.2 Arbitrary File Upload
CVE-2024-9422 - 6.6CVE-2023-52134: GEO my WordPress <= 4.0.2 SQL Injection
CVE-2023-52134 - 6.4CVE-2023-5467: GEO my WordPress <= 4.0 Stored Cross-Site Scripting
CVE-2023-5467
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C