CVE-2026-110530

FeedWordPress <= 2026.0517 - Unauthenticated Stored Cross-Site Scripting via Syndicated Feed Content

2026-10-30 20:11
Adrien Brunner

Strategic Overview

Status
Patched in 2026.1016
Affected Plugin
FeedWordPress
Affected Version
<= 2026.0517
CVSS
7.2High
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-110530
View all FeedWordPress vulnerabilities

At a glance

CVE-2026-110530 is a high-severity Improper Neutralization of Input During Web Page Generation vulnerability in the FeedWordPress WordPress plugin, affecting versions <= 2026.0517. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 2026.1016; sites on affected versions should update now. Disclosed October 2026, reported by Adrien Brunner.

Vulnerability Overview

The FeedWordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting in versions up to, and including, 2026.0517 via syndicated RSS/Atom feed content. The plugin's SyndicatedPost::sanitize_content() function only strips the 'target' attribute (the lines that would strip 'style' and 'on[a-z]+' event-handler attributes are commented out), and SyndicatedPost::insert_post() deliberately removes WordPress's wp_filter_kses and wp_filter_post_kses filters from content_save_pre before persisting imported feed items via wp_insert_post(). This makes it possible for unauthenticated attackers who control an external feed that a site has already subscribed to to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

FeedWordPress <= 2026.0517 carries this weakness at target, and reaching it takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For FeedWordPress the fix is 2026.1016: builds <= 2026.0517 are affected, anything from 2026.1016 onward is not.

Remediation

Update to version 2026.1016, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: FeedWordPress 2026.1016 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C