EventON – Events Calendar <= 2.5.7 - Authenticated (Subscriber+) Stored Cross-Site Scripting
Strategic Overview
- Status
- Patched in 2.5.8
- Affected Plugin
- EventON – Events Calendar
- Affected Version
<= 2.5.7- CVSS
- 6.4Medium
- Weakness type
- CWE-79 · Improper Neutralization of Input During Web Page Generation
- CVE
CVE-2026-81791
At a glance
CVE-2026-81791 is a medium-severity Improper Neutralization of Input During Web Page Generation vulnerability in the EventON WordPress plugin, affecting versions <= 2.5.7. It carries a CVSS score of 6.4 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 2.5.8; sites on affected versions should update now. Disclosed September 2026, reported by Nguyen Ba Khanh.
Vulnerability Overview
The EventON – Events Calendar plugin for WordPress is vulnerable to Stored Cross-Site Scripting in all versions up to, and including, 2.5.7. This is due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
Technical Analysis
The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.
CWE-79: Improper Neutralization of Input During Web Page Generation
Reaching this weakness in EventON <= 2.5.7 takes an account at Subscriber level or above. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.
Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For EventON the fix is 2.5.8: builds <= 2.5.7 are affected, anything from 2.5.8 onward is not.
Remediation
Update to version 2.5.8, or a newer patched version
How does WordSec protect against this?
An attacker needs Subscriber access first, so the firewall sees the attempt as traffic from a logged-in account: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: EventON 2.5.8 closes this, and updating the plugin is the step that ends it.
- Firewall
- Alerts
External References
Related records
Same weakness class
- 6.1CVE-2024-0233: EventON… (Pro) & <= 2.2.7 (Free) - Reflected XSS
CVE-2024-0233 - 6.1CVE-2023-4635: EventON <= 2.2.2 Reflected Cross-Site Scripting
CVE-2023-4635 - 4.4CVE-2024-6910: EventON <= 2.2.16 Stored Cross-Site Scripting
CVE-2024-6910 - 4.4CVE-2024-33940: EventON <= 2.2.14 Stored Cross-Site Scripting
CVE-2024-33940
Other vulnerabilities in EventON – Events Calendar
- 9.8CVE-2025-32614: EventON <= 2.4 Local File Inclusion
CVE-2025-32614 - 8.8CVE-2025-47494: EventON <= 2.4.1 Local File Inclusion
CVE-2025-47494 - 8.8CVE-2025-32160: EventON <= 2.4.1 Local File Inclusion
CVE-2025-32160 - 7.5CVE-2023-3219: EventON <= 2.1 IDOR to Unauthorized Post Access
CVE-2023-3219 - 7.2CVE-2024-6180: EventON Unauthenticated Stored XSS and Plugin Settings
CVE-2024-6180 - 6.5CVE-2023-6158: EventON… & Free <= 2.2.7 - Missing Authorization
CVE-2023-6158 - 6.5CVE-2023-6244: EventON - WordPress… (Pro) & <= 2.2.8 (Free) - CSRF
CVE-2023-6244 - 6.5CVE-2023-6242: EventON - WordPress… & Free <= 2.2.7 - CSRF
CVE-2023-6242
Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C