CVE-2026-110964

Essential Real Estate 4.4.3 - 5.3.4 - Authenticated (Subscriber+) Insecure Direct Object Reference

2026-11-04 00:00
sungbyeongchan

Strategic Overview

Status
Patched in 5.3.5
Affected Plugin
Essential Real Estate
Affected Version
4.4.3 – 5.3.4
CVSS
4.3Medium
Weakness type
CWE-639 · Authorization Bypass Through User-Controlled Key
CVE
CVE-2026-110964
View all Essential Real Estate vulnerabilities

At a glance

CVE-2026-110964 is a medium-severity Authorization Bypass Through User-Controlled Key vulnerability in the Essential Real Estate WordPress plugin, affecting versions 4.4.3 – 5.3.4. It carries a CVSS score of 4.3 (reachable over the network; low attack complexity). Exploitation requires an authenticated account at Subscriber level or above. The issue is fixed in version 5.3.5; sites on affected versions should update now. Disclosed November 2026, reported by sungbyeongchan.

Vulnerability Overview

The Essential Real Estate plugin for WordPress is vulnerable to Insecure Direct Object Reference in versions 4.4.3 through 5.3.4. This is due to missing validation on a user controlled key. This makes it possible for authenticated attackers, with subscriber-level access and above, to perform an unauthorized action.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no interaction from a victim user.

CWE-639: Authorization Bypass Through User-Controlled Key

Reaching this weakness in Essential Real Estate 4.4.3 – 5.3.4 takes an account at Subscriber level or above. Authorization bypass through a user-controlled key, often called insecure direct object reference, means the application looks up a record by an identifier from the request without checking that the caller owns it.

Changing a number in the request is enough to read or modify other users' records, which on commerce and membership sites means customer data. For Essential Real Estate the fix is 5.3.5: builds 4.4.3 – 5.3.4 are affected, anything from 5.3.5 onward is not.

Remediation

Update to version 5.3.5, or a newer patched version

How does WordSec protect against this?

Because it turns on account access, WordSec's login security is the relevant layer: role-based two-factor, captcha and brute-force limits raise the cost of getting the account this needs. None of that substitutes for the fix: Essential Real Estate 5.3.5 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C