CVE-2026-118205

Essential Addons for Elementor <= 6.8.7 - Unauthenticated Privilege Escalation to 'page_id' Parameter via Elementor Revision

2026-10-30 14:51
crow

Strategic Overview

Status
Patched in 6.8.8
Affected Version
<= 6.8.7
CVSS
7.4High
Weakness type
CWE-269 · Improper Privilege Management
CVE
CVE-2026-118205
View all Essential Addons for Elementor – Popular Elementor Templates & Widgets vulnerabilities

At a glance

CVE-2026-118205 is a high-severity Improper Privilege Management vulnerability in the Essential Addons for Elementor WordPress plugin, affecting versions <= 6.8.7. It carries a CVSS score of 7.4 (reachable over the network; high confidentiality, integrity impact). Exploitation requires no authentication. The issue is fixed in version 6.8.8; sites on affected versions should update now. Disclosed October 2026, reported by crow.

Vulnerability Overview

The Essential Addons for Elementor – Popular Elementor Templates & Widgets plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 6.8.7 via the `page_id` parameter of the `register_user()` function. The vulnerability exists because the handler's post status deny-list rejects `future`, `draft`, and `pending` but admits `inherit` — the status carried by every WordPress revision — allowing an attacker to substitute a revision ID for a live page ID, while a flawed "last saved by administrator" check reads `post_author` on revisions (which reflects the editing administrator) rather than the `_edit_last` meta that is never copied to revisions, and the nonce gate is rendered ineffective because any unauthenticated visitor can freely obtain a valid nonce via the `wp_ajax_nopriv_eael_get_token` endpoint. This makes it possible for unauthenticated attackers to register an account with a role as high as Editor — gaining capabilities including `edit_others_posts`, `publish_pages`, `upload_files`, and `unfiltered_html` — by naming a revision whose `_elementor_data` contains an elevated role an administrator previously saved and later reverted on a page bearing the Login/Register widget. Successful exploitation requires that the site has "Anyone can register" enabled and that an administrator has at some point saved and then reverted a non-default "New User Role" on an affected page.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, and no privileges on the target site, and no interaction from a victim user. A successful exploit has high impact on confidentiality, integrity.

CWE-269: Improper Privilege Management

Essential Addons for Elementor <= 6.8.7 carries this weakness at register_user(), and reaching it takes no account at all. Improper privilege management means the code lets an account end up with capabilities its role should not have.

It converts a low-privileged account into an administrative one, which makes every other restriction on the site irrelevant. For Essential Addons for Elementor the fix is 6.8.8: builds <= 6.8.7 are affected, anything from 6.8.8 onward is not.

Remediation

Update to version 6.8.8, or a newer patched version

How does WordSec protect against this?

This one needs no account at all, which puts it outside what login hardening can reach; WordSec's login security narrows the account-level paths around it, and the firewall is what inspects the request itself. None of that substitutes for the fix: Essential Addons for Elementor 6.8.8 closes this, and updating the plugin is the step that ends it.

  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C