CVE-2026-96894

ERP: Complete HR, Accounting & CRM Suite Built for WooCommerce <= 1.17.10 - Unauthenticated Stored Cross-Site Scripting via Inbound Email Body

2026-10-30 16:19
rpgsec

Strategic Overview

Status
Patched in 1.17.11
Affected Version
<= 1.17.10
CVSS
7.2High
Weakness type
CWE-79 · Improper Neutralization of Input During Web Page Generation
CVE
CVE-2026-96894
View all ERP: Complete HR, Accounting & CRM Suite Built for WooCommerce vulnerabilities

At a glance

CVE-2026-96894 is a high-severity Improper Neutralization of Input During Web Page Generation vulnerability in the ERP WordPress plugin, affecting versions <= 1.17.10. It carries a CVSS score of 7.2 (reachable over the network; low attack complexity). Exploitation requires no authentication. The issue is fixed in version 1.17.11; sites on affected versions should update now. Disclosed October 2026, reported by rpgsec.

Vulnerability Overview

The ERP: Complete HR, Accounting & CRM Suite Built for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Inbound Email Body in all versions up to, and including, 1.17.10 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The inbound email router's only gate is a regex match on the References header for a reply token whose hash is never cryptographically validated, meaning any external party who received or can mimic a CRM outbound email can satisfy the check without a WordPress account.

Technical Analysis

The vector marks this flaw as remotely reachable over the network, with low attack complexity — no special timing or configuration is needed, and no privileges on the target site, and no interaction from a victim user.

CWE-79: Improper Neutralization of Input During Web Page Generation

Reaching this weakness in ERP <= 1.17.10 takes no account at all. Cross-site scripting happens when input from a request is written into a page without being escaped for the context it lands in, so the browser parses attacker-supplied text as markup or script.

Injected script runs with the privileges of whoever views the affected page, which is how these flaws turn into administrator session theft, silent account creation or persistent backdoors in page content. For ERP the fix is 1.17.11: builds <= 1.17.10 are affected, anything from 1.17.11 onward is not.

Remediation

Update to version 1.17.11, or a newer patched version

How does WordSec protect against this?

Requests carrying this pattern arrive without a session, so nothing upstream of the firewall gets a chance to reject them: WordSec's web application firewall inspects request payloads before WordPress loads them. None of that substitutes for the fix: ERP 1.17.11 closes this, and updating the plugin is the step that ends it.

  • Firewall
  • Login Security
  • Alerts

External References

Related records

Vulnerability data © Defiant, Inc., provided under the Wordfence Intelligence T&C